Customer Issue
When an employee or contractor leaves the company, their Firstup account is expected to be automatically deactivated (blocked). However, we are seeing some users still in activated status when they should be deactivated.
Environment
- Creator Studio | People | Users
- User Sync/Spacestation/SFTP
Cause
A user will not be deactivated automatically if one of the following is true:
- The user was not created via user sync, and has never been included in a file. Ways a user could be created outside of user sync:
- Bulk import via Studio Import - Users
- Manual creation in Studio - Add a User
- SSO sign in
- The user was previously blocked automatically via user sync, but they have since been manually unblocked by a Studio user.
The attribute "Primary Email Source" can be a good indicator of how a user was created, as this stores the source of the user's email address. If this is anything other than "space station," then the user's email did not come from your user data file.
Another good indicator that a user didn't come from your file is that the user's profile is missing attributes that should have come from your file.
If the user definitely was previously in a file but now isn't deactivated, then this leaves you with the explanation that they have since been manually activated by a Studio user.
Resolution
If a user is identified that is not being automatically deprovisioned by user sync due to the reasons described above, then they will need to be deactivated manually from Studio.
The following method describes how this can be done in bulk for a large number of users:
- Create an audience containing these users. To convert a list of employee IDs or emails into an audience query: Create an Audience via Copy and Paste.
Take great care that this audience contains only the expected users. Failure to do so could result in unwanted users losing access to the platform. - Make make sure "Include deactivated users" is NOT ticked so that only currently activated users are included. Then take a snapshot of this audience. This can be used to roll back/reactivate previously activated users if needed.
- Filter the Users list by the created Audience.
- Select all filtered users and confirm that the expected number of users is selected.
DO NOT proceed if the number of selected users does not exactly match the number of users that you want to deactivate. - Click Deactivate.
- Depending on the number of changes to be processed, updates may not be immediate. You'll know that the bulk deactivate has been fully processed when the audience created in step 2 contains no users (as deactivated users are not included).
To roll back, instead filter to the snapshot that was taken for step 3 and click Activate instead of Deactivate.
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